dynagen動作確認3 IPv6初設定

自分にとってこれまで全く未知の世界にも等しかったIPv6の世界に、この日足を踏み出しました。

IPv6の概論をしっかり読み、アドレスの種類を把握してようやく
設定を入れることができました。

今回行った動作確認は以下のとおりです。

画像


今回は各ルータにサイトローカルアドレスを設定しました。
これは、IPv4のプライベートアドレスにあたります。
サイトローカルアドレスには

FEC0::/10

というアドレスが頭につくのが特徴です。



設定中のトラブルは、
IPv6アドレスの桁を間違えて入力していた、というところです。
0を続けて入力するのでつい0を1つ多くしてアドレッシングしてしまっていました。

スタティックルーティングはIPv4と同じ書式で実行できます。
簡単でした。



以下、R1のsh runとsh ipv6 routeの内容を記載します。

R1#sh run
Building configuration...

Current configuration : 1094 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jRht$KAWGeMrESHMQ4bBtHbcNg1
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
!
multilink bundle-name authenticated
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
ipv6 address FEC0:1::1/64
serial restart-delay 0
!
interface Serial1/1
no ip address
ipv6 address FEC0:2::1/64
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
!
ip http server
no ip http secure-server
!
ipv6 route FEC0:3::/64 FEC0:1::2
ipv6 route FEC0:4::/64 FEC0:2::2

!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R1#sh ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C FEC0:1::/64 [0/0]
via ::, Serial1/0
L FEC0:1::1/128 [0/0]
via ::, Serial1/0
C FEC0:2::/64 [0/0]
via ::, Serial1/1
L FEC0:2::1/128 [0/0]
via ::, Serial1/1
S FEC0:3::/64 [1/0]
via FEC0:1::2
S FEC0:4::/64 [1/0]
via FEC0:2::2
L FF00::/8 [0/0]
via ::, Null0

R1#ping fec0:3::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:3::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/63/88 ms

R1#ping fec0:4::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:4::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/63/88 ms


ルーティングの状況を見るときに、
sh ip routeではでてこなかったです。

IPv6のルーティング状況を見るなら、
sh ipv6 routeを使う必要があることを知りました。

このコマンドで、
「S」はスタティックルーティングを意味します。
これはIPv4と同じですね。「L」については後日書く機会が出てくるでしょう。

次はIPv6でEIGRPを動かしてみます。

問題集消化率:1%未満

ブログ気持玉

クリックして気持ちを伝えよう!

ログインしてクリックすれば、自分のブログへのリンクが付きます。

→ログインへ

なるほど(納得、参考になった、ヘー)
驚いた
面白い
ナイス
ガッツ(がんばれ!)
かわいい

気持玉数 : 0

この記事へのコメント

この記事へのトラックバック