dynagenを使った動作確認2 EIGRP編1

今回からは実際にdynagenを使って動作確認したことをupしていきます。

まずはEIGRPから。

EIGRPってただ動かすだけなら簡単に動いてしまうなぁと下の演習をやってみて思いました。


演習1 router3つで稼働させてみる。

画像


特筆なし。普通に動きました。


演習2 router4つで稼働させてみる。

画像


画像内にある検証内容にあるように、ここでは接続断の状態から収束までの様子を
debug eigrp packetsコマンドを使ってみてみました。

ここで起きたトラブルは、
debugの実行を止めようと思って

#no debug packet

と入力しても、少しもデバッグ出力が止まらずにまるで暴走してるんじゃないかと
思ってしまったこと。

原因はコマンドの打ち間違いでした。

つまり、debug eigrp packetsによる出力を止めるには

#no debug eigrp packets

と入力しなければならないということ。何でもないようなことなのに、
延々とログが出力され続ける中で正しい取り消しコマンドを入れるのは
以外と大変だと思いました。


演習3 router4つで稼働させてみる2

画像


ここでは、R1-R2間でhelloパケットの送出間隔の数値を変えてみて
それで

show ip eigrp neighbors

を使って内容を確認してみましたのですが、
ここでもトラブルが発生しました。

R1(config-if)#ip hello-interval eigrp 1 10

としているのに対向側では、R1から送出されたhelloパケットを
変更前と同じ5秒ごとに受け取っています。
あれ? 設定が反映されてない?

これはおかしいと原因を探してみてようやく判明しました。
原因は確認すべき対向側のルータはR2なのに、実際はR3で
show ip eigrp neighbors
を実行していたのです。これでは確かに確認できませんね。

今度はR2で上記のコマンドを叩いてみると、
きちんと10秒ごとにhelloパケットを受け取っていることを確認できました。


演習4 フレームリレーを介したEIGRP

画像


dynagenではフレームリレースイッチを使うことができます。

設定の仕方については、

ccstudy
http://ccstudy.org/
のdinamipsの記事で確認できます。

ここでは、この演習で使用した.netファイルをお見せします。

[localhost]

[[3725]]
image = \Program Files\Dynamips\images\c3725-adventerprisek9-mz.124-11.T.bin
ram = 128

[[ROUTER R1]]
model = 3725
console = 2001
s1/0 = FR 1
autostart = False
idlepc = 0x602c462c


[[router R2]]
model = 3725
console = 2002
s1/0 = FR 2
autostart = False
idlepc = 0x60c64128


[[router R3]]
model = 3725
console = 2003
s1/0 = FR 3
autostart = False
idlepc = 0x60c64128


[[router R4]]
model = 3725
console = 2004
s1/0 = FR 4
autostart = False
idlepc = 0x60c64128


[[frsw FR]]
1:102 = 2:201
1:103 = 3:301
1:104 = 4:401

トポロジーと.netファイルの関連が見えてきたのではないでしょうか。

検証内容②まで設定を入れて、疎通を確認してみます。
ハブ - スポーク間の疎通は問題なしでした。

R2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/41/68 ms

しかし、スポーク間ではpingが通りません。

R2#ping 10.1.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping 10.1.3.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

そこで、③の設定を追加します。
R1からR4のすべてのルータにEIGRPを実装します。

すると、今度はスポーク間でもpingの応答が帰ってくるようになりました。

R2#ping 10.1.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/75/108 ms
R2#ping 10.1.3.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/74/108 ms

R3で
show ip route
を実行してみると、しっかりルーティングされていました。

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
D 10.1.3.0 [90/2681856] via 10.1.2.1, 00:01:02, Serial1/0
C 10.1.2.0 is directly connected, Serial1/0
D 10.1.1.0 [90/2681856] via 10.1.2.1, 00:01:02, Serial1/0

これで4つのルータすべてが通信できるようになりました。

最後にハブルータであるR1と、
スポークルータであるR2のコンフィグを載せておきます。

R1#sh ru
*Mar 1 00:45:59.627: %SYS-5-CONFIG_I: Configured from console by consolen
Building configuration...

Current configuration : 1428 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Tbzo$QFTKW1rso9rFbnNeQFA2U/
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 10.1.1.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/0.2 point-to-point
ip address 10.1.2.1 255.255.255.0
frame-relay interface-dlci 103
!
interface Serial1/0.3 point-to-point
ip address 10.1.3.1 255.255.255.0
frame-relay interface-dlci 104
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
network 10.1.3.0 0.0.0.255
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!!
line con 0
line aux 0
line vty 0 4
!
!
end


R2#sh
*Mar 1 00:26:00.115: %SYS-5-CONFIG_I: Configured from console by console run
Building configuration...

Current configuration : 1035 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$OQ2k$xSD1ESsPuvRIbzJ3OWhcD0
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 201
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end


さて、次回はIPv6を使ったEIGRPの動作確認を行います☆

問題集消化率:1%未満

ブログ気持玉

クリックして気持ちを伝えよう!

ログインしてクリックすれば、自分のブログへのリンクが付きます。

→ログインへ

なるほど(納得、参考になった、ヘー)
驚いた
面白い
ナイス
ガッツ(がんばれ!)
かわいい

気持玉数 : 0

この記事へのコメント

この記事へのトラックバック